OpenSSL Security Breach

This week, you may have heard a big stir about ‘Heartbleed‘ in the global news. It’s the nickname for a bug found in OpenSSL which has affected over half a million websites, including trusted names such as Yahoo, Instagram, OK Cupid, Event Brite and Squidoo. It’s one of the most serious breaches of online security in recent years.

OpenSSL is an encryption tool widely used to protect personal data. The scariest part is, it looks like the bug has been around since December 2011 – and they’ve only just discovered it. This could leave your information vulnerable to exposure by hackers – from usernames and passwords to credit card information and private emails. Unfortunately, there’s no way to tell whether or not a site has been compromised. Due to that fact, web security firms are advising all potentially affected websites to update their SSL certificates, and then for their users to change passwords for online sensitive data.

To be on the safe side, we’re taking all the precautions here at T Dispatch; our OpenSSL certificates are being replaced today, and we encourage our drivers and controllers to change their passwords once this has been done (3pm GMT). Controllers can do this by logging in to T Dispatch and entering their profile (click on the bottom left user icon). Drivers should go to and use the ‘password reset’ link.

For all of you who have limo, minicab or taxi booking websites, or online dispatch systems, we’d recommend you check if OpenSSL is used to know whether or not your customer data is vulnerable. If it is, you must update your software before urging users to change their passwords, otherwise the change will be ineffective. This severe bug leaves no trace where it’s been, so there’s no way of knowing whether or not you’ve been spied on for the last 2 years.

Read more about this issue at